Microsoft has implemented a fix for the global Azure authentication issue, and our services have fully recovered.
All users should now be able to log in and access our applications without interruption.
We will continue to monitor for any residual impact, but no further disruptions are expected.
Thank you for your patience and understanding during this incident.
Posted Oct 29, 2025 - 15:23 CDT
Update
We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 15:23 CDT
Monitoring
Microsoft has identified the root cause of the global Azure outage impacting authentication services. They are actively implementing a fix, and expect services to be restored soon.
We will continue to monitor closely and provide updates once full functionality has been confirmed.
Thank you for your continued patience.
Posted Oct 29, 2025 - 14:27 CDT
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 11:04 CDT
Investigating
We are currently experiencing an outage affecting access to our applications. The issue is related to a global Microsoft Azure outage, which impacts our authentication services.
As a result, users may be unable to log in to our websites or encounter intermittent access issues.
We are actively monitoring Azure’s status and will provide updates as more information becomes available.
Thank you for your patience while we work to restore normal access.
Posted Oct 29, 2025 - 11:04 CDT
This incident affected: TestHound, Pathways, and Evaluation.